Project

General

Profile

Bug #191

AddContact - unbindservice ....

Added by Vincent Véronis over 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
User Interface
Target version:
Start date:
07/12/2009
Due date:
% Done:

100%

Estimated time:
Affected version:
0.1.8
Locale:
Close

Description

07-12 15:51:44.933: ERROR/AndroidRuntime(884): Uncaught handler: thread main exiting due to uncaught exception
07-12 15:51:44.953: ERROR/AndroidRuntime(884): java.lang.RuntimeException: Unable to stop activity {com.beem.project.beem/com.beem.project.beem.ui.AddContact}: java.lang.IllegalArgumentException: Service not registered: com.beem.project.beem.ui.AddContact$BeemServiceConnection@4381ed00
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at android.app.ActivityThread.performDestroyActivity(ActivityThread.java:3097)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at android.app.ActivityThread.handleDestroyActivity(ActivityThread.java:3159)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at android.app.ActivityThread.access$2400(ActivityThread.java:112)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1724)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at android.os.Handler.dispatchMessage(Handler.java:99)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at android.os.Looper.loop(Looper.java:123)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at android.app.ActivityThread.main(ActivityThread.java:3948)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at java.lang.reflect.Method.invokeNative(Native Method)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at java.lang.reflect.Method.invoke(Method.java:521)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:782)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:540)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at dalvik.system.NativeStart.main(Native Method)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): Caused by: java.lang.IllegalArgumentException: Service not registered: com.beem.project.beem.ui.AddContact$BeemServiceConnection@4381ed00
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at android.app.ActivityThread$PackageInfo.forgetServiceDispatcher(ActivityThread.java:839)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at android.app.ApplicationContext.unbindService(ApplicationContext.java:843)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at android.content.ContextWrapper.unbindService(ContextWrapper.java:312)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at com.beem.project.beem.ui.AddContact.onStop(AddContact.java:51)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at android.app.Instrumentation.callActivityOnStop(Instrumentation.java:1245)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at android.app.Activity.performStop(Activity.java:3564)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): at android.app.ActivityThread.performDestroyActivity(ActivityThread.java:3092)
07-12 15:51:44.953: ERROR/AndroidRuntime(884): ... 11 more

Scenario :

Je suis dans le addContact.
Je recois une demande d'ajout de contact.
Je valide la demande.
Je me retrouve sur le addContact
Je fais une fleche pour retourner sur la contact list => Crash !

Y en a marre de se service .... !!!!!!!!!!!!


Related issues

Related to Bug #192: Event listener dans BeemService et de XmppConnectionAdapterClosed2009-09-10

History

#1 Updated by Nikita Kozlov over 9 years ago

  • Status changed from New to Feedback
  • Assignee set to Nikita Kozlov
  • % Done changed from 0 to 100

#2 Updated by Frédéric Barthéléry over 9 years ago

  • Status changed from Feedback to Resolved

Resolved i think

#3 Updated by Frédéric Barthéléry about 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF