Project

General

Profile

Bug #215

Crash à la reconnexion lorsque l'on est deja connecte

Added by Jean-Baptiste Vergely almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
11/19/2009
Due date:
% Done:

100%

Estimated time:
1.00 h
Affected version:
0.1.8
Locale:
Close

Description

Lorsque l'on est connecté avec son compte: menu -> settings -> menu -> login l'application crash.

Le problème se produit lorsque l'on modifie ou non des options.

Rapport d'erreur:

11-19 17:20:23.207: WARN/dalvikvm(992): threadid=3: thread exiting with uncaught exception (group=0x4001aa28)
11-19 17:20:23.207: ERROR/AndroidRuntime(992): Uncaught handler: thread main exiting due to uncaught exception
11-19 17:20:23.217: ERROR/AndroidRuntime(992): java.lang.RuntimeException: Error receiving broadcast Intent { act=BeemConnectionClosed (has extras) } in com.beem.project.beem.utils.BeemBroadcastReceiver@43821998
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at android.app.ActivityThread$PackageInfo$ReceiverDispatcher$Args.run(ActivityThread.java:716)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at android.os.Handler.handleCallback(Handler.java:587)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at android.os.Handler.dispatchMessage(Handler.java:92)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at android.os.Looper.loop(Looper.java:123)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at android.app.ActivityThread.main(ActivityThread.java:4203)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at java.lang.reflect.Method.invokeNative(Native Method)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at java.lang.reflect.Method.invoke(Method.java:521)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:791)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:549)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at dalvik.system.NativeStart.main(Native Method)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): Caused by: java.lang.IllegalArgumentException: Service not registered: com.beem.project.beem.ui.ContactList$BeemServiceConnection@437590c0
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at android.app.ActivityThread$PackageInfo.forgetServiceDispatcher(ActivityThread.java:880)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at android.app.ApplicationContext.unbindService(ApplicationContext.java:865)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at android.content.ContextWrapper.unbindService(ContextWrapper.java:324)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at com.beem.project.beem.utils.BeemBroadcastReceiver.onReceive(BeemBroadcastReceiver.java:42)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): at android.app.ActivityThread$PackageInfo$ReceiverDispatcher$Args.run(ActivityThread.java:705)
11-19 17:20:23.217: ERROR/AndroidRuntime(992): ... 9 more
11-19 17:20:23.227: INFO/Process(573): Sending signal. PID: 992 SIG: 3
11-19 17:20:23.227: INFO/dalvikvm(992): threadid=7: reacting to signal 3
11-19 17:20:23.227: ERROR/dalvikvm(992): Unable to open stack trace file '/data/anr/traces.txt': Permission denied

History

#1 Updated by Vincent Véronis almost 10 years ago

  • Status changed from New to Closed
  • Assignee set to Vincent Véronis
  • % Done changed from 0 to 100
  • Estimated time set to 1.00 h

Manage login change.

Also available in: Atom PDF