Project

General

Profile

Bug #220

Plantage lorsque l'on tente de modifier les paramètres après une annulation de connexion

Added by Jean-Baptiste Vergely over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
11/20/2009
Due date:
% Done:

100%

Estimated time:
5.00 h
Affected version:
0.1.8
Locale:
Close

Description

Problème, lorsque l'on arrive sur la page de connexion de BEEM et que l'on effectue la manip suivante:

touche retour (annulation de la connexion) > menu > settings > Modification des paramètres > login. Normalement il se passe rien, pas de reconnexion ni rien.

Si on tente de re-rentrer dans le menu, l'appli plante mais pas complétement car on reste sur BEEM.

rapport d'erreurs:

11-20 16:20:27.814: WARN/dalvikvm(807): threadid=3: thread exiting with uncaught exception (group=0x4000fe70)
11-20 16:20:27.814: ERROR/AndroidRuntime(807): Uncaught handler: thread main exiting due to uncaught exception
11-20 16:20:27.934: ERROR/AndroidRuntime(807): java.lang.RuntimeException: Unable to stop activity {com.beem.project.beem/com.beem.project.beem.ui.Login}: java.lang.IllegalArgumentException: Service not registered: com.beem.project.beem.ui.Login$BeemServiceConnection@43744198
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at android.app.ActivityThread.performStopActivityInner(ActivityThread.java:2905)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at android.app.ActivityThread.handleStopActivity(ActivityThread.java:2948)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at android.app.ActivityThread.access$2100(ActivityThread.java:112)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1708)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at android.os.Handler.dispatchMessage(Handler.java:99)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at android.os.Looper.loop(Looper.java:123)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at android.app.ActivityThread.main(ActivityThread.java:3948)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at java.lang.reflect.Method.invokeNative(Native Method)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at java.lang.reflect.Method.invoke(Method.java:521)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:782)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:540)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at dalvik.system.NativeStart.main(Native Method)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): Caused by: java.lang.IllegalArgumentException: Service not registered: com.beem.project.beem.ui.Login$BeemServiceConnection@43744198
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at android.app.ActivityThread$PackageInfo.forgetServiceDispatcher(ActivityThread.java:839)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at android.app.ApplicationContext.unbindService(ApplicationContext.java:843)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at android.content.ContextWrapper.unbindService(ContextWrapper.java:312)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at com.beem.project.beem.ui.Login.onStop(Login.java:107)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at android.app.Instrumentation.callActivityOnStop(Instrumentation.java:1245)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at android.app.Activity.performStop(Activity.java:3564)
11-20 16:20:27.934: ERROR/AndroidRuntime(807): at android.app.ActivityThread.performStopActivityInner(ActivityThread.java:2902)

History

#1 Updated by Jean-Baptiste Vergely over 9 years ago

MAJ: Le problème intervient aussi lorsque l'on appuie sur la touche "Home" ou bien la touche "prendre un appel".

#2 Updated by Vincent Véronis over 9 years ago

  • Status changed from New to Resolved
  • Assignee set to Frédéric Barthéléry
  • % Done changed from 0 to 100
  • Estimated time set to 5.00 h

Manage login change.

#3 Updated by Frédéric Barthéléry over 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF