Project

General

Profile

Bug #227

Gestion contact Hors ligne

Added by Jean-Baptiste Vergely over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
User Interface
Target version:
Start date:
12/13/2009
Due date:
% Done:

100%

Estimated time:
Affected version:
0.1.8
Locale:
Close

Description

Quand je vais dans menu ==> paramètres => Liste d'ami(e)s => cocher la case pour afficher les amis déconnectés . Je retourne dans ma liste de contact et je commence à scroller, l'application plante. Les logs sont les suivants:

12-13 15:38:25.436: WARN/dalvikvm(816): threadid=3: thread exiting with uncaught exception (group=0x4001aa28)
12-13 15:38:25.436: ERROR/AndroidRuntime(816): Uncaught handler: thread main exiting due to uncaught exception
12-13 15:38:25.446: ERROR/AndroidRuntime(816): java.lang.NullPointerException
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at com.beem.project.beem.ui.ContactList$BeemContactList.getView(ContactList.java:635)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.widget.AbsListView.obtainView(AbsListView.java:1255)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.widget.ListView.makeAndAddView(ListView.java:1658)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.widget.ListView.fillDown(ListView.java:637)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.widget.ListView.fillGap(ListView.java:608)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.widget.AbsListView.trackMotionScroll(AbsListView.java:2489)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.widget.AbsListView.onTouchEvent(AbsListView.java:1977)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.widget.ListView.onTouchEvent(ListView.java:3195)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.view.View.dispatchTouchEvent(View.java:3672)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:850)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:882)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:882)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:882)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:882)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:882)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at com.android.internal.policy.impl.PhoneWindow$DecorView.superDispatchTouchEvent(PhoneWindow.java:1712)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at com.android.internal.policy.impl.PhoneWindow.superDispatchTouchEvent(PhoneWindow.java:1202)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.app.Activity.dispatchTouchEvent(Activity.java:1987)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at com.android.internal.policy.impl.PhoneWindow$DecorView.dispatchTouchEvent(PhoneWindow.java:1696)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.view.ViewRoot.handleMessage(ViewRoot.java:1658)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.os.Handler.dispatchMessage(Handler.java:99)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.os.Looper.loop(Looper.java:123)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at android.app.ActivityThread.main(ActivityThread.java:4203)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at java.lang.reflect.Method.invokeNative(Native Method)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at java.lang.reflect.Method.invoke(Method.java:521)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:791)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:549)
12-13 15:38:25.446: ERROR/AndroidRuntime(816): at dalvik.system.NativeStart.main(Native Method)

Autre Problème, si je souhaite réafficher mes contacts hors lignes je n'ai pas de refresh automatique.

History

#1 Updated by Nikita Kozlov over 9 years ago

  • Category set to User Interface
  • Status changed from New to Feedback
  • Assignee set to Nikita Kozlov
  • Target version set to 0.1
  • % Done changed from 0 to 100

Cannot reproduce with the last sources ?

#2 Updated by Frédéric Barthéléry over 9 years ago

Nikita Kozlov wrote:

Cannot reproduce with the last sources ?

For me too. Sorry I have fix this without even notice.
(PS: Ahem 3h du mat l'anglais c'est moyeb)

#3 Updated by Frédéric Barthéléry over 9 years ago

  • Status changed from Feedback to Closed

Solved

Also available in: Atom PDF