Project

General

Profile

Bug #230

Crash when receiving a message sent by my account but on another resource

Added by Romain Vimont almost 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Communication
Target version:
Start date:
01/07/2010
Due date:
% Done:

100%

Estimated time:
Affected version:
hg
Locale:
Close

Description

I am connected twice with the same account : once on my computer (/laptop) and once on my phone (/phone).
On the computer, with Gajim (all don't do that), I can send a message to another connected resource of the same account : I see myself in the contact list without having to add myself as a contact. When I sent such a message to my resource "phone", my phone doesn't show the message and beem crashes.

I tested with Jabiru (http://jabiru.mzet.net/), another jabber client for android which is not maintainne anymore, and it works. So it should be a bug in beem.

--------
(je ne vais pas toujours traduire mes bug reports, mais vu que j'avais commencé par le français, autant le laisser)

Je suis connecté deux fois avec le même compte : une fois sur mon pc (/laptop) et une fois sur mon téléphone (/phone).
Sur le pc, grâce à Gajim (tous ne le font pas), je peux envoyer un message à une autre ressource connectée du même compte : je me vois en tant que connecté sans même m'être ajouté à ma liste de contacts. Lorsque j'envoie un tel message à ma ressource "phone", mon téléphone n'affiche pas le message et ça fait planter beem.

J'ai testé avec Jabiru (http://jabiru.mzet.net/), un autre client jabber pour android qui ne semble plus maintenu, et là ça fonctionne. Ça doit donc être un bug dans beem.

History

#1 Updated by Frédéric Barthéléry almost 10 years ago

  • Subject changed from Crash lors de l'envoi d'un message à partir d'une autre ressource du même compte to Crash when receiving a message sent by my account but on another resource

#2 Updated by Romain Vimont almost 10 years ago

It doesn't crash anymore, but I don't receive the message…

#3 Updated by Nikita Kozlov over 9 years ago

  • Status changed from New to Assigned
  • Assignee set to Nikita Kozlov
  • Target version set to 0.1.3
  • Affected version set to hg

#4 Updated by Frédéric Barthéléry over 9 years ago

  • Target version changed from 0.1.3 to 0.2

#5 Updated by Frédéric Barthéléry over 9 years ago

  • Status changed from Assigned to Resolved
  • Target version changed from 0.2 to 0.1.4

Seems to be solved on trunk on r726. may be since the 0.1.3 release.

#6 Updated by Nikita Kozlov over 9 years ago

  • % Done changed from 0 to 100

Work for me.
Anyone has that bug recently ?

#7 Updated by Frédéric Barthéléry over 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF