Project

General

Profile

Bug #258

Close/Crash when screen is powered off

Added by Anonymous over 7 years ago. Updated about 7 years ago.

Status:
Assigned
Priority:
Normal
Category:
-
Target version:
Start date:
04/19/2010
Due date:
% Done:

0%

Affected version:
0.1.x
Locale:
Close

Description

Hello

First the problem:
I start beem and connect to the jabber server.
My phone has a 30 sec timer to switch the display off.
When I unlock my phone after some minutes, the icon in the notify area is gone.
My status changed to offline (checked with pc jabber client).
The funny thing is, there is still a beem process running (task killer show the process).
When I open beem again, it reconnects to the server.

I don’t know if this is a normal behavior or a crash of the background service.
It looks like a crash of the background service, but maybe there is a strange “don’t use power” thing running?

Other application like 3G Traffic counter are not crashing after unlock the phone.

Second my system:
I have a HTC Legend with Android 2.1, the latest beem (0.1.3) version and use a connection to my own jabber server with TLS.

When you need more information let it me please know.
Anyway very good jabber client, thanks a lot for the good work. :)

Kind regards

Manuel


Related issues

Related to Feature #259: Improve support for reconnections Assigned 04/19/2010

History

#1 Updated by Frédéric Barthéléry over 7 years ago

Hi

Do you use wifi to connect to your server ?
If yes, I think you are switching from wifi to 3G so you lose the connection to your server and BEEM just stop.
There is some work in progress to improve the automatic reconnection of Beem and you can follow it on feature #259 or on the mailing list.
The feature should should be in the next release.

#2 Updated by ge la over 7 years ago

Frédéric Barthéléry wrote:

Hi

Do you use wifi to connect to your server ?
If yes, I think you are switching from wifi to 3G so you lose the connection to your server and BEEM just stop.
There is some work in progress to improve the automatic reconnection of Beem and you can follow it on feature #259 or on the mailing list.
The feature should should be in the next release.

Hello

No, I do not use wifi. I only use the 3G-Network, but I seems to switch a lot between HSDPA and EDGE. Maybe this is the source of the problem.

#259 sounds like the problem where I tried to descript.

#3 Updated by Luke Hospadaruk over 7 years ago

I've also had this problem on a G1, and it's not due to the wifi (since I don't use it). It might be the reconnection issue nonetheless, perhaps if my phone looses service for a moment, or my home-cooked openfire server stutters in some unexpected way.

It doesn't seem to be definitively tied to the screen turning off, sometimes beem will remain connected for dozens of minutes of the screen being turned off, and it seems if I have the application open, it will remain connected indefinitely (although I'm not 100% sure there).

If there's any further info you need/could use, I'd be happy to gather/generate it for you.

#4 Updated by Frédéric Barthéléry about 7 years ago

  • Status changed from New to Assigned
  • Target version set to 0.2
  • Assignee set to Frédéric Barthéléry
  • Priority changed from High to Normal

Also available in: Atom PDF