Project

General

Profile

Bug #311

I need force old 5223 ssl support

Added by Anonymous over 8 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
10/29/2010
Due date:
% Done:

0%

Estimated time:
Affected version:
0.1.x
Locale:
Close

Description

Hi, our company use xmpp, but the server need to use force old 5223 ssl, so I cannot connect to the server use beem, thanks

Beem-debug.apk (736 KB) Beem-debug.apk Nikita Kozlov, 12/08/2010 07:41 PM
asmack-android-7-beem.jar (1.03 MB) asmack-android-7-beem.jar Nikita Kozlov, 12/08/2010 07:41 PM
51-smack_ssl_legacy.patch (6.37 KB) 51-smack_ssl_legacy.patch Nikita Kozlov, 12/08/2010 07:41 PM

Related issues

Related to Support #312: SSL error: unknown protocol for 0.1.4Closed2010-11-10

History

#1 Updated by Nikita Kozlov over 8 years ago

Here is a patch that enable the feature : http://issues.igniterealtime.org/browse/SMACK-274

#2 Updated by Nikita Kozlov over 8 years ago

I have rewrited the patch to make it "asmack compliant" and fixed a small bug on it.

Unfortunately I have tested only if there were no regression in the tls part.

So if someone could test it with a xmpp server having legacy ssl enabled, it will save me the time of installing this kind of server myself (if not, I will try to find some time to test the legacy ssl part too) :)

I'm adding, the rewrited patch, a patched asmack lib, and an apk build in debug mode.

PS: I doubt the legacy ssl code will work out of the box, I think it need some more hacking on it.

#3 Updated by David Jensen over 8 years ago

I'm in need of this too and I'd like to help debugging.
We use a zimbra server at work wich requires legacy ssl, I tried you're patched apk above and it failed for me.
What can I do to help you debug? logs?

#4 Updated by Rob Isakson almost 8 years ago

@Nikita I can verify that the APK you posted works properly. However, I don't see the code to add the preference setting to the android code, I only see the patch to the asmack library. Can you post the changes you made to the layouts?

#5 Updated by Rob Isakson almost 8 years ago

I've also encountered an issue where enabling SSL will crash on devices running android <=2.2. Works great on Gingerbread (2.3) but creashes with a "java.security.NoSuchAlgorithmException: SSLContext SSL implementation not found" error (Full Stacktrace). The posts I have looked at say its caused by the cert bring self signed. I've set "mConnectionConfiguration.setSelfSignedCertificateEnabled(true);" in the BeamService.java, however, it still errors out.

#6 Updated by Johannes Michler almost 8 years ago

This is great. Just tried this with our Oracle Collaboration Suite XMPP Server (that is just doing SSL over the XMPP protocol). Your apk is working fine. Can we get this into trunk? (Using Cyanogenmod 7.1-nightly (gingerbread).

Thanks a lot for this patch, this makes beem the only xmpp client working with Oracle Collaboration Suite in SSL-Mode!!

Regarding SSL: For us we're having a free xmpp-certificate by startssl.com, this is working fine. But I think it would be a good idea to allow self-signed certificates. But for now this is better than everything else on android :-)

#7 Updated by Frédéric Barthéléry over 6 years ago

  • Status changed from New to Rejected

Patch is available if you really need it. But it is better to upgrade server (or change for an implementation up to date with the standard if you can)

Also available in: Atom PDF