Project

General

Profile

Bug #321

Exception when username does not have an @

Added by Anonymous almost 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
XMPP
Target version:
Start date:
12/17/2010
Due date:
% Done:

100%

Estimated time:
Affected version:
0.1.x
Locale:
Close

Description

If you set your own server, and your username does not have an @, beem will crash on connect.

beem-log.txt (4.55 KB) beem-log.txt Beem trace m c, 01/03/2011 01:30 PM

Associated revisions

Revision 844:30d32b73be7c (diff)
Added by Nikita Kozlov almost 8 years ago

fix Bug #321
I have commented the PrivacyListManagerAdapter initialization because the exception came from the underneath code.
Also, since the feature isn't finished (especially tested) and enabled in the gui, it will be safer.

Revision 865:30d32b73be7c (diff)
Added by Nikita Kozlov almost 8 years ago

fix Bug #321
I have commented the PrivacyListManagerAdapter initialization because the exception came from the underneath code.
Also, since the feature isn't finished (especially tested) and enabled in the gui, it will be safer.

Revision 844:30d32b73be7c (diff)
Added by Nikita Kozlov almost 8 years ago

fix Bug #321
I have commented the PrivacyListManagerAdapter initialization because the exception came from the underneath code.
Also, since the feature isn't finished (especially tested) and enabled in the gui, it will be safer.

History

#1 Updated by Nikita Kozlov almost 8 years ago

  • Category set to XMPP
  • Status changed from New to Assigned
  • Assignee set to Nikita Kozlov
  • Target version set to 0.1.5
  • Affected version changed from 0.2 to 0.1.x

#2 Updated by Nikita Kozlov almost 8 years ago

I cannot reproduce the issue when using the trunk version, need more info or it may already be fixed.

#3 Updated by Nikita Kozlov almost 8 years ago

  • Status changed from Assigned to Feedback

#4 Updated by m c almost 8 years ago

Same bug here. Using:
User: user@server
Password: password
Server: server
works but return "wrong password or user". Indeed my login should be "user"
Using:
User: user
Password: password
Server: server
Does not work, Beem terminates. When starting again, Beem tries to connect automaticaly and ... terminates again. I have about 1seconde to press "abort".

#5 Updated by Frédéric Barthéléry almost 8 years ago

Can you provide us a stack trace with logcat ? I cannot reproduce the problem too.
Your username should be a full JID ; user@server. only the user part is used to authenticate.

#6 Updated by m c almost 8 years ago

Your username should be a full JID ; user@server. only the user part is used to authenticate.

Ok, however the connection fails and returns "wrong password or user". Using the same username and password, I can connect with my computer.
Is there character limitation for the password? It contains characters like #,'. and so on.

--> It seems that I was using a buggy web page to check my password on the apinc.org server. There is no problem with the password when using beem.

Can you provide us a stack trace with logcat ?
Ok, I tried to reproduce the problem, in fact, it is not so easy. Until now, I thought that the problem occured every time.
However, it seems that the problem occurs only if you previously abort a connection. Example:
- I try to connect with:
User: user@server
Password: password
Server: server
- I abort the connection
- I change the username to "user" (remove @server)
- I try to connect.
- Then the programm leaves.

Notice, I'm using the 0.1.4 found on android market.

You will find here the trace obtained with aLogcat, it seems that all begin with this line:
W/dalvikvm(14686): threadid=39: thread exiting with uncaught exception (group=0x2aaca450)

Best regards,

M. Charbonnier.

#7 Updated by Nikita Kozlov almost 8 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

I have unsuccessfully tried to reproduce your crash by following your indications.

Also, looking at your log, it look like that something went bad in PrivacyListManager code so I have commented the line that initialize it in xmppconnection creation (anyway, since it's unfinished/untested it was a bad idea to let it be initialized).

It will be helpful if you could retest with the (at least) tonight nightlybuild or with the future 1.5 release.

#8 Updated by Frédéric Barthéléry almost 8 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF