Project

General

Profile

Bug #383

Erreur survenue sur le serveur

Added by Anonymous almost 10 years ago. Updated almost 10 years ago.

Status:
Rejected
Priority:
Normal
Category:
-
Target version:
Start date:
01/07/2012
Due date:
% Done:

0%

Estimated time:
Affected version:
0.1.6
Locale:
Close

Description

Je viens d'installer un serveur Jabber (prosody), j'arrive à m'y connecter sans problème sur le PC avec Empathy ou Gajim, mais avec Beem (0.1.6), dès que je me connecte il m'affiche "Erreur survenu(e) sur le serveur" (il manque le 'e' au passage dans le message).

Mon serveur a été installé comme ceci : http://blog.rom1v.com/2012/01/heberger-un-serveur-jabber-simplement-prosody/

#1

Updated by Romain Vimont almost 10 years ago

(c'était de moi le bug report, j'avais oublié de me connecter)

Il semblerait que le problème vienne d'IPv6 : beem n'arrive pas à se connecter sur une adresse IPv6. J'ai récupéré les sources et exécuté sur mon téléphone à partir d'Eclipse pour avoir la stacktrace, j'ai ceci :

01-07 14:43:33.036: E/XMPPConnectionAdapter(10537): XMPPError connecting to rom1v.com:5222.: remote-server-error(502) XMPPError connecting to rom1v.com:5222.
01-07 14:43:33.036: E/XMPPConnectionAdapter(10537): -- caused by: java.net.ConnectException: rom1v.com/2a01:e34:eecb:13c0:82ee:73ff:fe07:95ce:5222 - Connection refused

Si au lieu de me connecter à rom1v.com (dont le DNS contient à la fois AAAA et A), je me connecte à ipv4.rom1v.com (qui ne contient que l'entrée A), ça fonctionne (mais l'authentification ne fonctionne pas, car mon JID n'est pas en @ipv4.rom1v.com).

#2

Updated by Romain Vimont almost 10 years ago

En gardant le JID en @rom1v.com et en précisant dans options spécifiques le serveur ipv4.rom1v.com, ça fonctionne…

Par contre j'ai regardé dans le code, à première vue je dirais que ça vient de la lib asmack… À vérifier…

#3

Updated by Frédéric Barthéléry almost 10 years ago

  • Status changed from New to Rejected
  • Assignee set to Frédéric Barthéléry
  • Target version set to 0.1.7

Not a bug.
Your prosody server does not listen on ipv6. You have to configure your dns SRV records to direct on the ipv4 interface.
See http://wiki.xmpp.org/web/SRV_Records#XMPP_SRV_records

Also available in: Atom PDF