Project

General

Profile

Bug #489

digest-uri wrong when using separate server

Added by Anonymous about 6 years ago. Updated about 6 years ago.

Status:
New
Priority:
Normal
Assignee:
Beem-Core
Category:
Communication
Target version:
-
Start date:
03/25/2013
Due date:
% Done:

0%

Estimated time:
Affected version:
0.1.x
Locale:
Close

Description

Hi,

when configuring a separate server for connection, this
server IP or domain is used as the digest uri. This is wrong
for virtual hosts, which are very common.

Solution:
Introduce option to use domain of Jabber-ID as digest uri
(even when domain is not fully qualified as without ".com" or so,
like "myjabber" or "mygroup".

Example:

Jabber-ID: user@virthost
Server: xmpp.veryltd.com

In this case there is a virtual host "virthost" configured in jabber at
the server xmpp.veryltd.com. The digest uri therefore should be "virthost"
otherwise authentication fails.

Thanks a lot!

What steps will reproduce the problem?
1.
2.
3.

What is the expected output? What do you see instead?

What version of Beem are you using? On what Android version? On what device?

Please provide any additional information below.


Related issues

Is duplicate of Bug #472: Failed to login - error in SASL authentificationAssigned2012-12-30

History

#1 Updated by Frédéric Barthéléry about 6 years ago

  • Tracker changed from Feature to Bug
  • Subject changed from digest-uri wrong when using separate server to digest-uri wrong when using separate server
  • Description updated (diff)
  • Affected version set to 0.1.x

Also available in: Atom PDF